PerformancePoint 2010 Dashboard Designer – ‘An unexpected system error has occurred’ when adding a data connection

16 04 2010

Whilst trying to setup a PerformancePoint 2010 dashboard on my SharePoint 2010 boot to vhd environment today I received this error message – ‘An unexpected system error has occured’…’ when adding a data connection in the Dashboard Designer.

A couple of Google searches didn’t turn up much but did point me towards the ‘Secure Store Service’ – this can be found in Central Administration > Manage Service Applications.

The service was started but when I tried to manage the service I received another error stating that the service was not responding!

It was then that I realised – the environment in question did not contain the pre-requisite WCF hotfix which is required for SharePoint 2010 to install on Windows Server 2008 R2. This machine had actually been been upgraded from Windows Server 2008 x64 to Server 2008 R2 x64 (this was the SharePoint Information Worker VHD) therefore the hotfix did not exist.

I was worried I would have to re-install SharePoint after installing the hotfix but it turns out you don’t need to, just follow the steps below –

  1. Download the Windows Server 2008 R2 WCF hotfix (there are two versions of this patch and the latest is version 2 – ‘Windows6.1-KB976462-v2-x64.msu’), get it from here – KB976462
  2. Install the hotfix and reboot the machine
  3. Run the SharePoint Products and Technologies configuration wizard – PSCONFIG
  4. Proceed through the wizard and it will upgrade your SharePoint farm
  5. Check in Central Administration and you should now be able to successfully manage the ‘Secure Store Service’ and Dashboard Designer should work!!

Hope this helps 🙂

Advertisements